请选择 进入手机版 | 继续访问电脑版

挂坊论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 7|回复: 0

[源码发布] 易语言流程控制计次循环首

[复制链接]

11

主题

11

帖子

26

积分

初入论坛

Rank: 2

积分
26
发表于 2020-6-27 13:08:52 | 显示全部楼层 |阅读模式
本帖最后由 am927 于 2020-6-27 13:14 编辑

计次循环首子易语言循环命令中是使用非常频繁的一个命令,教程罗列了多个历程说明示范了该命令的使用技巧。

一、官方文档

调用格式: 〈无返回值〉 计次循环首 (整数型 循环次数,[整数型变量 已循环次数记录变量]) - 系统核心支持库->流程控制
英文名称:counter
执行本命令将把循环体内的命令重复执行指定的次数。提供的整数参数值决定将重复执行的次数。本命令为初级命令。
参数<1>的名称为“循环次数”,类型为“整数型(int)”。本数值指定执行计次循环体内所有命令的次数,必须大于等于零。
参数<2>的名称为“已循环次数记录变量”,类型为“整数型(int)”,可以被省略,提供参数数据时只能提供变量。本数值型变量用作记录当前循环首已经被进入过的次数(从 1 开始),程序可以直接取用此变量中的值。

操作系统需求: Windows、Linux、Unix

对应命令:
调用格式: 〈无返回值〉 计次循环尾 () - 系统核心支持库->流程控制
英文名称:CounterLoop
本命令已经被隐藏。
如果计次循环的循环次数未到,执行本命令将返回到对应的“计次循环首”命令处继续进行循环,否则将顺序执行下一条命令退出本计次循环。本命令为初级命令。

操作系统需求: Windows、Linux、Unix

二、举例源码:

方法1




  1. .版本 2

  2. .子程序 例1
  3. .局部变量 n, 整数型画板1.清除 (, , , )
  4. .计次循环首 (9, n)
  5. ' 画板1.写出 (到文本 (n) + #换行符)
  6. ' 画板1.写文本行 (n)
  7. 画板1.滚动写行 (n)
  8. .计次循环尾 ()
复制代码

方法2


  1. .版本 2

  2. .子程序 例2
  3. .局部变量 i, 整数型
  4. .局部变量 输出内容, 文本型画板1.清除 (, , , )
  5. .计次循环首 (9, i)
  6. 输出内容 = 输出内容 + “☆”
  7. 画板1.滚动写行 (输出内容)
  8. .计次循环尾 ()
复制代码

方法3


  1. .版本 2

  2. .子程序 例3
  3. .局部变量 m, 整数型编辑框1.内容 = “”
  4. .计次循环首 (9, m)
  5. .计次循环首 (m, )
  6. 编辑框1.加入文本 (“☆”)
  7. .计次循环尾 ()
  8. 编辑框1.加入文本 (#换行符)
  9. .计次循环尾 ()
复制代码

方法4



  1. .版本 2

  2. .子程序 例4
  3. .局部变量 m, 整数型编辑框1.内容 = “”
  4. .计次循环首 (9, m)
  5. .计次循环首 (10 - m, )
  6. 编辑框1.加入文本 (“☆”)
  7. .计次循环尾 ()
  8. 编辑框1.加入文本 (#换行符)
  9. .计次循环尾 ()
复制代码

方法5


  1. .版本 2

  2. .子程序 例5
  3. .局部变量 n, 整数型编辑框1.内容 = “”
  4. .计次循环首 (9, n)
  5. .计次循环首 (10 - n, )
  6. 编辑框1.加入文本 (字符 (#空格键))
  7. .计次循环尾 ()
  8. .计次循环首 (n, )
  9. 编辑框1.加入文本 (“▲”)
  10. .计次循环尾 ()
  11. 编辑框1.加入文本 (#换行符)
  12. .计次循环尾 ()
复制代码

方法6


游客,如果您要查看本帖隐藏内容请回复

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
挂坊论坛交流群                           赚坊币                   开通VIP免坊币                   咨询请教
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|挂坊论坛 ( 苏ICP备20001813号 )

GMT+8, 2020-7-12 00:52 , Processed in 0.078125 second(s), 30 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表