请选择 进入手机版 | 继续访问电脑版

挂坊论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 218|回复: 1

[网页游戏辅助源码] 江中游模块源码分享

[复制链接]

43

主题

44

帖子

421

积分

初级会员

Rank: 3Rank: 3

积分
421
发表于 2019-5-30 11:02:31 | 显示全部楼层 |阅读模式
江中游模块源码结合了大漠多线程、windows、多线程、江中游、大漠中文的内容。

备注:
本模块为VIP调用使用,故开源给大家,希望大家珍惜资源,不要把模块源码给其它人”, “声明:只做技术交流,严禁商业行为”,

  1. .版本 2

  2. .程序集 多线程, , 公开

  3. .子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用



  4. .子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用



  5. .子程序 启动, 逻辑型, 公开, 新建并启动一个线程,返回真表示成功,假表示失败。
  6. .参数 欲执行的子程序, 子程序指针
  7. .参数 参数数据, 整数型, 可空
  8. .参数 线程句柄, 整数型, 参考 可空
  9. .局部变量 句柄, 整数型

  10. 线程句柄 = 0
  11. 句柄 = CreateThread (0, 0, 欲执行的子程序, 参数数据, 0, 0)
  12. .如果 (是否为空 (线程句柄))
  13.     CloseHandle (句柄)
  14. .否则
  15.     线程句柄 = 句柄
  16. .如果结束
  17. 返回 (句柄 ≠ 0)


  18. .子程序 创建许可证, 多线程许可证, 公开
  19. .局部变量 许可证x, 多线程许可证, 静态

  20. InitializeCriticalSection (许可证x)
  21. 返回 (许可证x)

  22. .子程序 删除许可证, , 公开
  23. .参数 进入许可证, 多线程许可证

  24. DeleteCriticalSection (进入许可证)

  25. .子程序 进入许可区, , 公开
  26. .参数 进入许可证, 多线程许可证

  27. EnterCriticalSection (进入许可证)

  28. .子程序 退出许可区, , 公开
  29. .参数 进入许可证, 多线程许可证

  30. LeaveCriticalSection (进入许可证)

  31. .子程序 指定CPU核心, 整数型, 公开, 设置CPU亲和性  进程句柄  返回CPU号SetProcessAffinityMask
  32. .参数 进程句柄, 整数型, 可空, hProcess,自身进程-1,为空默认为-1
  33. .参数 CPU核心, 整数型, 可空, 可以相加,推荐1,为空默认为1。参考:CPU的线程数量(数字),如果CPU为四线程,那么CPU的序号分别为1,2,4,8,如果设置为3,表示由第一、二线程运行,如果设置为15(15=1+2+4+8),那么表示四线程全部运行
  34. .局部变量 返回, 整数型

  35. .如果真 (是否为空 (进程句柄))
  36.     进程句柄 = -1
  37. .如果真结束
  38. .如果真 (是否为空 (CPU核心))
  39.     CPU核心 = 1
  40. .如果真结束
  41. 返回 = 为进程指定CPU_ (进程句柄, CPU核心)
  42. 返回 (返回)

  43. .子程序 等待, 逻辑型, 公开
  44. .参数 线程句柄, 整数型
  45. .参数 等待时间, 整数型, 可空, 单位为毫秒,0和-1表示无限等待
  46. .局部变量 ret, 整数型

  47. 等待时间 = 选择 (是否为空 (等待时间), 5 × 1000, 等待时间)
  48. .循环判断首 ()
  49.     ret = MsgWaitForMultipleObjects (1, 线程句柄, 假, 等待时间, 1215)
  50.     处理事件 ()
  51. .循环判断尾 (ret ≠ 0 且 ret ≠ 258)  ' 0:所有的对象都发出信号,258:超时
  52. 返回 (WaitForSingleObject (线程句柄, 选择 (是否为空 (等待时间), -1, 选择 (等待时间 = 0, -1, 等待时间))) = 0)

  53. .子程序 挂起, 逻辑型, 公开
  54. .参数 线程句柄, 整数型

  55. 返回 (SuspendThread (线程句柄) = 0)

  56. .子程序 继续, 逻辑型, 公开, 继续运行被挂起的线程
  57. .参数 线程句柄, 整数型

  58. 返回 (ResumeThread (线程句柄) = 1)

  59. .子程序 取返回值, 整数型, 公开, 使用前请保证线程已经运行完毕,如线程尚未中断将返回STILL_ACTIVE(值为259)。子程序返回值为其他数据类型将返回指针。
  60. .参数 线程句柄, 整数型
  61. .局部变量 返回值, 整数型

  62. GetExitCodeThread (线程句柄, 返回值)
  63. 返回 (返回值)

  64. .子程序 取状态, 整数型, 公开, 返回0表示该线程不存在(或句柄已被关闭),返回1为运行完毕,2为正在运行。
  65. .参数 线程句柄, 整数型
  66. .局部变量 返回值, 整数型

  67. .如果真 (GetExitCodeThread (线程句柄, 返回值) = 0)
  68.     返回 (0)
  69. .如果真结束
  70. .如果真 (返回值 ≠ 259)
  71.     返回 (1)
  72. .如果真结束
  73. 返回 (2)

  74. .子程序 强制结束, 逻辑型, 公开
  75. .参数 线程句柄, 整数型

  76. 返回 (TerminateThread (线程句柄, 0) ≠ 0)

  77. .子程序 关闭句柄, 逻辑型, 公开
  78. .参数 线程句柄, 整数型

  79. .如果真 (GetExitCodeThread (线程句柄, 0) ≠ 0)
  80.     返回 (CloseHandle (线程句柄) ≠ 0)
  81. .如果真结束
  82. 返回 (假)

  83. .子程序 取当前句柄, 整数型, 公开

  84. 返回 (GetCurrentThreadId ())

  85. .子程序 结束当前线程, 逻辑型, 公开, 退出当前所在线程,成功返回真,失败返回假,也可使用易语言的:返回() 命令返回应该返回文本型返回值。
  86. .参数 线程返回值, 整数型, , 此值不能为259,线程的返回值,可以使用 取线程返回值 获取此返回值。

  87. 返回 (ExitThread (线程返回值) ≠ 0)

复制代码




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
加入挂坊高手群                           赚坊币                   开通VIP送坊币

0

主题

13

帖子

1

积分

新手观察

Rank: 1

积分
1
发表于 2019-8-18 07:04:31 | 显示全部楼层
感觉不错!支持一下!
加入挂坊高手群                           赚坊币                   开通VIP送坊币
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|挂坊论坛

GMT+8, 2020-2-25 04:12 , Processed in 0.109375 second(s), 30 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表