请选择 进入手机版 | 继续访问电脑版

挂坊论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 215|回复: 0

[网页游戏辅助源码] 易语言辅助强登源码

[复制链接]

43

主题

43

帖子

171

积分

初级会员

Rank: 3Rank: 3

积分
171
发表于 2019-5-30 11:48:23 | 显示全部楼层 |阅读模式
易语言辅助强登源码结合了DLL命令定义表、图片资源表、常量数据表、窗口程序集_启动窗口等内容,学习很有价值。



  1. .版本 2
  2. .支持库 eNetIntercept
  3. .支持库 iext
  4. .支持库 EThread

  5. .程序集 窗口程序集_启动窗口
  6. .程序集变量 环境, 网络服务安装
  7. .程序集变量 Sk, Win_Socket
  8. .程序集变量 游戏套接口, 整数型
  9. .程序集变量 游戏封包, 字节集
  10. .程序集变量 服务器IP, 文本型
  11. .程序集变量 服务套接口1, 整数型
  12. .程序集变量 服务套接口2, 整数型
  13. .程序集变量 二次套接, 整数型
  14. .程序集变量 状态, 整数型

  15. .子程序 __启动窗口_创建完毕

  16. 晴天_专用皮肤2 ()
  17. 无视插件 ()
  18. 监视热键 (&重装程序, #F12键)
  19. 监视热键 (&注入插件, #End键)

  20. .子程序 重装程序

  21. .如果真 (信息框 (“不能使用软件时再重新安装!”, #确认取消钮, “温馨提示:”) = #取消钮)
  22.     返回 ()
  23. .如果真结束
  24. 环境.卸载 ()
  25. 写到文件 (取运行目录 () + “\LSP_Repare.bat”, #LSP)
  26. 置文件属性 (取运行目录 () + “\LSP_Repare.bat”, #隐藏文件)
  27. 运行 (取运行目录 () + “\LSP_Repare.bat”, 假, 1)
  28. 信息框 (“请重启强登!”, 0, , )
  29. 删除文件 (取运行目录 () + “\LSP_Repare.bat”)
  30. 结束 ()

  31. .子程序 无视插件

  32. .如果真 (环境.是否已安装 () = 假)
  33.     写到文件 (取运行目录 () + “\TP强登.dll”, #ESPI)
  34.     置文件属性 (取运行目录 () + “\TP强登.dll”, #隐藏文件)
  35.     .如果 (环境.安装 (取运行目录 () + “\TP强登.dll”) = 假)
  36.         信息框 (“加载环境失败!请重新打开!”, 0, , )
  37.     .否则

  38.     .如果结束
  39.     删除文件 (取运行目录 () + “\TP强登.dll”)
  40. .如果真结束
  41. PQ筱焱S.打开 ()

  42. .子程序 __启动窗口_将被销毁

  43. PQ筱焱S.关闭 ()
  44. 环境.卸载 ()

  45. .子程序 Hurt_调连接, 整数型
  46. .参数 调用者信息, 调用者信息, 参考
  47. .参数 套接字句柄, 整数型, 参考
  48. .参数 网址, 网址信息, 参考
  49. .局部变量 IP, 字节型, , "4"
  50. .局部变量 port, 整数型

  51. .如果真 (到小写 (取文本右边 (调用者信息.取进程名 (), 13)) = 到文本 ({ 99, 114, 111, 115, 115, 102, 105, 114, 101, 46, 101, 120, 101 }))
  52.     网址.取IP端口 (IP [1], IP [2], IP [3], IP [4], port)
  53.     .如果真 (port = 10008)
  54.         状态 = 1  ' 用于窗口标题,防OD搜索文本
  55.         是否可断开 = 真
  56.         服务器IP = 到文本 (IP [1]) + “.” + 到文本 (IP [2]) + “.” + 到文本 (IP [3]) + “.” + 到文本 (IP [4])
  57.         .如果真 (二次套接 ≠ 0)
  58.             Sk.关闭连接 (二次套接)
  59.             Sk.销毁套接口 (二次套接)
  60.         .如果真结束
  61.         二次套接 = Sk.申请套接口 ()
  62.         Sk.置阻塞模式 (二次套接)
  63.     .如果真结束
  64.     .如果真 (port = 13006)
  65.         是否可断开 = 假
  66.         计数 = 0
  67.         状态 = 0

  68.     .如果真结束

  69. .如果真结束
  70. 返回 (0)

  71. .子程序 Hurt_调发送, 整数型
  72. .参数 调用者信息, 调用者信息, 参考
  73. .参数 套接字句柄, 整数型, 参考
  74. .参数 网络数据, 网络数据, 参考
  75. .参数 调用方式, 整数型, 参考
  76. .局部变量 data, 字节集

  77. 置入代码 ({ 235, 16, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 98, 101, 103, 105, 110, 0 })  ' VMP过程加密开始
  78. .如果真 (是否可断开 且 到小写 (取文本右边 (调用者信息.取进程名 (), 13)) = 到文本 ({ 99, 114, 111, 115, 115, 102, 105, 114, 101, 46, 101, 120, 101 }))
  79.     data = 网络数据.到字节集 ()
  80.     发送计次 = 发送计次 + 1
  81.     _启动窗口.标题 = “Hurt强制登器V1.0 - 连接成功”
  82.     透明标签5.标题 = “Hurt强登器已发送封包数据:” + 到文本 (发送计次) + “条”
  83.     更改标题 (取句柄 (“crossfire.exe”, “CrossFire”, “穿越火线”), “Hurt强登就是这么吊!给力奔放!”)
  84.     .如果真 (取字节集左边 (data, 2) = { 241, 144 })
  85.         S_Data = data
  86.         启动线程 (&sking, , )
  87.         发送 = 发送 + 1
  88.         返回 (0)
  89.     .如果真结束
  90.     .如果真 (寻找字节集 (data, { 50, 51, 45, 49 }, ) ≠ -1)
  91.         S_Data = data
  92.         启动线程 (&sking, , )
  93.         发送 = 发送 + 1
  94.         返回 (1)
  95.     .如果真结束
  96.     .如果真 (寻找字节集 (data, { 241, 51, 0 }, ) ≠ -1)
  97.         S_Data = data
  98.         启动线程 (&sking, , )
  99.         发送 = 发送 + 1
  100.         返回 (1)
  101.     .如果真结束
  102.     .如果真 (寻找字节集 (data, { 241, 32, 3, 0, 25 }, ) ≠ -1)
  103.         S_Data = data
  104.         启动线程 (&sking, , )
  105.         发送 = 发送 + 1
  106.         返回 (1)
  107.     .如果真结束
  108.     .如果真 (二次套接 ≠ 0)
  109.         Sk.关闭连接 (二次套接)
  110.         Sk.销毁套接口 (二次套接)
  111.         二次套接 = Sk.申请套接口 ()
  112.         Sk.绑定 (二次套接)
  113.     .如果真结束
  114.     返回 (0)

  115. .如果真结束
  116. 返回 (0)
  117. 置入代码 ({ 235, 14, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 101, 110, 100, 0 })  ' VMP过程加密结束

  118. .子程序 Hurt_调接收, 整数型
  119. .参数 调用者信息, 调用者信息, 参考
  120. .参数 套接字句柄, 整数型, 参考
  121. .参数 网络数据, 网络数据, 参考
  122. .参数 调用方式, 整数型, 参考
  123. .局部变量 data, 字节集
  124. .局部变量 发送数据, 文本型

  125. 石头超强加密保护开始 ()
  126. .如果真 (是否可断开 且 到小写 (取文本右边 (调用者信息.取进程名 (), 13)) = 到文本 ({ 99, 114, 111, 115, 115, 102, 105, 114, 101, 46, 101, 120, 101 }))
  127.     data = 网络数据.到字节集 ()
  128.     发送数据 = 字节集到十六进制 (网络数据.到字节集 ())
  129.     接收计次 = 接收计次 + 1
  130.     .如果真 (寻找文本 (发送数据, “F1”, , 假) ≠ -1 且 寻找文本 (发送数据, “01EC”, , 假) ≠ -1 且 寻找文本 (发送数据, “533132332D3220”, , 假) ≠ -1)
  131.         网络数据.从字节集分配 (十六进制到字节集 (#拦截232))
  132.         返回 (2)
  133.     .如果真结束
  134.     .如果真 (寻找文本 (发送数据, “D3C3BBA7D0ADD2E9”, , 假) ≠ -1)
  135.         网络数据.从字节集分配 (字节集替换 (网络数据.到字节集 (), 3, 1, { 9 }))
  136.         返回 (2)
  137.     .如果真结束
  138.     .如果真 (寻找文本 (发送数据, “CAFDBEDDD2ECB3A3”, , 假) ≠ -1)
  139.         网络数据.从字节集分配 (字节集替换 (网络数据.到字节集 (), 3, 1, { 9 }))
  140.         返回 (2)
  141.     .如果真结束
  142.     .如果真 (取字节集左边 (data, 5) = { 241, 168, 50, 1, 1 } 且 取字节集中间 (data, 7, 1) ≠ { 0 })
  143.         接收 = 接收 + 1
  144.         返回 (1)
  145.     .如果真结束
  146.     .如果真 (寻找字节集 (data, { 50, 51, 45, 50 }, ) ≠ -1)
  147.         S_Data = data
  148.         接收 = 接收 + 1
  149.         返回 (1)
  150.     .如果真结束
  151.     .如果真 (寻找字节集 (data, { 182, 212, 178, 187, 198, 240 }, ) ≠ -1)
  152.         S_Data = data
  153.         接收 = 接收 + 1
  154.         返回 (1)
  155.     .如果真结束
  156.     .如果真 (寻找字节集 (data, { 202, 253, 190, 221, 210, 236, 179, 163 }, ) ≠ -1)
  157.         S_Data = data
  158.         接收 = 接收 + 1
  159.         返回 (1)
  160.     .如果真结束
  161.     .如果真 (寻找字节集 (data, { 50, 51, 45, 48 }, ) ≠ -1)
  162.         S_Data = data
  163.         接收 = 接收 + 1
  164.         返回 (1)
  165.     .如果真结束
  166.     .如果真 (寻找字节集 (data, { 50, 51, 45, 49 }, ) ≠ -1)
  167.         S_Data = data
  168.         接收 = 接收 + 1
  169.         返回 (1)
  170.     .如果真结束
  171.     .如果真 (寻找字节集 (data, { 241, 51, 0 }, ) ≠ -1)
  172.         S_Data = data
  173.         接收 = 接收 + 1
  174.         返回 (1)
  175.     .如果真结束
  176.     .如果真 (寻找字节集 (data, { 241, 32, 3, 0, 25 }, ) ≠ -1)
  177.         S_Data = data
  178.         接收 = 接收 + 1
  179.         返回 (1)
  180.     .如果真结束
  181.     .如果真 (二次套接 ≠ 0)
  182.         Sk.关闭连接 (二次套接)
  183.         Sk.销毁套接口 (二次套接)
  184.         二次套接 = Sk.申请套接口 ()
  185.         Sk.绑定 (二次套接)
  186.     .如果真结束
  187.     返回 (0)
  188. .如果真结束
  189. 返回 (0)
  190. 石头超强加密保护结尾 ()

  191. .子程序 Hurt_调侦听, 整数型
  192. .参数 调用者信息, 调用者信息, 参考
  193. .参数 本地套接口, 整数型
  194. .参数 IP11, 字节型
  195. .参数 网络数据, 网络数据, 参考
  196. .参数 IP22, 字节型
  197. .参数 IP33, 字节型
  198. .参数 IP44, 字节型
  199. .参数 IP局部, 文本型
  200. .参数 本地, Win_Socket
  201. .参数 进程名, 文本型
  202. .参数 IP, 字节型
  203. .参数 状态, 整数型
  204. .参数 port, 整数型
  205. .参数 套接字句柄, 整数型, 参考
  206. .参数 数据IP, 文本型
  207. .参数 data, 字节集
  208. .参数 S_Data, 字节集
  209. .参数 二次套接
  210. .参数 连接IP, 文本型
  211. .参数 连接端口, 整数型
  212. .参数 端口, 整数型
  213. .参数 网址, 网址信息, 参考

  214. 进程名 = 取文本右边 (调用者信息.取进程名 (), 取文本长度 (调用者信息.取进程名 ()) - 倒找文本 (调用者信息.取进程名 (), “\”, , 假))
  215. .如果真 (端口 = 10008 且 进程名 = “crossfire.exe”)
  216.     .如果真 (到小写 (取文本右边 (调用者信息.取进程名 (), 取文本长度 (“crossfire.exe”))) = 到小写 (“crossfire.exe”))
  217.         网址.取IP端口 (IP [1], IP [2], IP [3], IP [4], port)
  218.         .如果真 (port = 10008)
  219.             是否断开 = 真
  220.             数据IP = 到文本 (IP [1]) + “.” + 到文本 (IP [2]) + “.” + 到文本 (IP [3]) + “.” + 到文本 (IP [4])
  221.             二次套接 = port
  222.             网址.置IP端口 (127, 0, 0, 1, 10008)
  223.             服务器IP = 数据IP
  224.         .如果真结束
  225.         网址.取IP端口 (IP11, IP22, IP33, IP44, 端口)
  226.         IP局部 = 到文本 (IP11) + “.” + 到文本 (IP22) + “.” + 到文本 (IP33) + “.” + 到文本 (IP44)
  227.         .如果真 (IP局部 ≠ “127.0.0.1” 且 端口 = 10008)
  228.             .如果真 (二次套接 ≠ 0)
  229.                 本地.关闭连接 (二次套接)
  230.                 本地.销毁套接口 (二次套接)
  231.                 网址.置IP端口 (127, 0, 0, 1, 10008)
  232.                 服务器IP = 数据IP
  233.             .如果真结束
  234.             二次套接 = 本地.申请套接口 ()
  235.             本地.置阻塞模式 (二次套接)
  236.             time = 0
  237.             Sk.置阻塞模式 (本地套接口)
  238.             网址.置IP端口 (127, 0, 0, 1, 10008)
  239.             本地套接口 = 本地.申请套接口 ()
  240.             Sk.绑定 (本地套接口, 10008, “”)
  241.             Sk.置阻塞模式 (本地套接口)
  242.             Sk.监听 (本地套接口, 10)
  243.             网址.置IP端口 (127, 0, 0, 1, 10008)
  244.             网址.置IP端口 (127, 0, 0, 1, 10008)
  245.             Sk.销毁套接口 (服务套接口1)
  246.             Sk.销毁套接口 (服务套接口2)
  247.             Sk.销毁套接口 (游戏套接口)
  248.             .循环判断首 ()
  249.                 .如果真 (Sk.接受 (本地套接口, 游戏套接口, -1) = 1)
  250.                     Sk.取客户信息 (游戏套接口, 连接IP, 连接端口)
  251.                     .如果真 (游戏套接口 ≠ 0 且 连接IP = “127.0.0.1”)
  252.                         Sk.销毁套接口 (本地套接口)
  253.                         服务套接口1 = 本地.申请套接口 ()
  254.                         Sk.置阻塞模式 (服务套接口1)
  255.                         Sk.连接 (服务套接口1, 服务器IP, 10008, -1)
  256.                         创建线程 (&转发游戏封包)
  257.                         服务套接口2 = 本地.申请套接口 ()
  258.                         Sk.置阻塞模式 (服务套接口2)
  259.                         Sk.连接 (服务套接口2, 服务器IP, 10008, -1)
  260.                         创建线程 (&转发服务封包)
  261.                         跳出循环 ()
  262.                     .如果真结束

  263.                 .如果真结束

  264.             .循环判断尾 (本地套接口 ≠ -1)
  265.             内存优化 (1)
  266.             网址.置IP端口 (127, 0, 0, 1, 10008)
  267.             网址.置IP端口 (127, 0, 0, 1, 10008)
  268.             网址.置IP端口 (127, 0, 0, 1, 10008)
  269.             网址.置IP端口 (127, 0, 0, 1, 10008)
  270.             网址.置IP端口 (127, 0, 0, 1, 10008)
  271.             网址.置IP端口 (127, 0, 0, 1, 10008)
  272.             .如果真 (port = 13006)
  273.                 是否断开 = 假
  274.                 发送 = 0
  275.                 接收 = 0
  276.                 状态 = 0
  277.             .如果真结束
  278.             返回 (2)
  279.         .如果真结束
  280.         .如果真 (到小写 (取文本右边 (调用者信息.取进程名 (), 13)) = 到文本 ({ 99, 114, 111, 115, 115, 102, 105, 114, 101, 46, 101, 120, 101 }))
  281.             Sk.置阻塞模式 (二次套接)
  282.             Sk.连接 (二次套接, 服务器IP, 10008, 100)
  283.             data = 网络数据.到字节集 ()
  284.             .如果真 (进程是否存在 (“crossfire.exe”))
  285.                 S_Data = data
  286.                 网址.取IP端口 (IP [1], IP [2], IP [3], IP [4], port)
  287.                 服务器IP = 到文本 (IP [1]) + “.” + 到文本 (IP [2]) + “.” + 到文本 (IP [3]) + “.” + 到文本 (IP [4])
  288.                 .如果真 (网址.置IP端口 (127, 0, 0, 1, 端口))
  289.                     返回 ()
  290.                 .如果真结束
  291.                 .如果真 (二次套接 ≠ 0)
  292.                     Sk.关闭连接 (二次套接)
  293.                     Sk.销毁套接口 (二次套接)
  294.                 .如果真结束
  295.                 二次套接 = Sk.申请套接口 ()
  296.                 .如果真 (Sk.连接 (二次套接, “127.0.0.1”, 80, -1))
  297.                     Sk.发送 (二次套接, data, -1)
  298.                     .循环判断首 ()
  299.                         输出调试文本 (到文本 (S_Data))
  300.                     .循环判断尾 (Sk.接收 (二次套接, S_Data, 3000) > 0)
  301.                     Sk.关闭连接 (二次套接)
  302.                 .如果真结束
  303.                 Sk.销毁套接口 (二次套接)
  304.             .如果真结束
  305.             返回 (0)

  306.         .如果真结束
  307.         返回 (#拦截操作.更改调用)

  308.     .如果真结束

  309. .如果真结束



  310. .子程序 S_link

  311. 置入代码 ({ 235, 16, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 98, 101, 103, 105, 110, 0 })  ' VMP过程加密开始
  312. Sk.连接 (二次套接, 服务器IP, 10008, 100)
  313. 高精度等待 (100)
  314. Sk.发送 (二次套接, 字节集替换 (S_Data, 920, 7, { 1, 2, 3, 4, 5, 20, 238 }))  ' 关键
  315. PQ筱焱S.刷新显示 ()
  316. PQ筱焱S.调整层次 ()
  317. 高精度等待 (20)
  318. Sk.连接 (二次套接, 服务器IP, 13006, 100)
  319. PQ筱焱S.刷新显示 ()
  320. PQ筱焱S.调整层次 ()
  321. 高精度等待 (20)
  322. Sk.发送 (二次套接, 字节集替换 (S_Data, 760, 5, { 1, 2, 3, 4, 5, 20, 238 }))
  323. PQ筱焱S.刷新显示 ()
  324. PQ筱焱S.调整层次 ()
  325. 高精度等待 (300)
  326. Sk.发送 (二次套接, 字节集替换 (B_Data, 760, 5, { 1, 2, 3, 4, 5, 20, 238 }))
  327. PQ筱焱S.刷新显示 ()
  328. PQ筱焱S.调整层次 ()
  329. 高精度等待 (10)
  330. Sk.发送 (二次套接, 字节集替换 (S_Data, 920, 7, { 1, 2, 3, 4, 5, 20, 238 }))
  331. PQ筱焱S.刷新显示 ()
  332. PQ筱焱S.调整层次 ()
  333. 置入代码 ({ 235, 14, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 101, 110, 100, 0 })  ' VMP过程加密结束
  334. 返回 ()

  335. .子程序 sking2

  336. 置入代码 ({ 235, 16, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 98, 101, 103, 105, 110, 0 })  ' VMP过程加密开始
  337. Sk.连接 (二次套接, 服务器IP, 10008, 100)
  338. 高精度等待 (1000)
  339. Sk.发送 (二次套接, 字节集替换 (S_Data, 920, 7, { 1, 2, 3, 4, 5, 20, 238 }))
  340. PQ筱焱S.刷新显示 ()
  341. PQ筱焱S.调整层次 ()
  342. 高精度等待 (20)
  343. Sk.连接 (二次套接, 服务器IP, 13006, 100)
  344. 高精度等待 (20)
  345. PQ筱焱S.刷新显示 ()
  346. PQ筱焱S.调整层次 ()
  347. Sk.发送 (二次套接, 字节集替换 (S_Data, 760, 5, { 1, 2, 3, 4, 5, 20, 238 }))
  348. PQ筱焱S.刷新显示 ()
  349. PQ筱焱S.调整层次 ()
  350. 高精度等待 (300)
  351. Sk.发送 (二次套接, 字节集替换 (B_Data, 760, 5, { 1, 2, 3, 4, 5, 20, 238 }))
  352. PQ筱焱S.刷新显示 ()
  353. PQ筱焱S.调整层次 ()
  354. 高精度等待 (10)
  355. 置入代码 ({ 235, 14, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 101, 110, 100, 0 })  ' VMP过程加密结束
  356. 返回 ()

  357. .子程序 转发游戏封包
  358. .局部变量 封包长度, 整数型

  359. .循环判断首 ()
  360.     封包长度 = Sk.接收 (游戏套接口, 游戏封包, -1)
  361.     .如果真 (封包长度 > 1 且 封包长度 < 99)  ' 10008
  362.         Sk.发送 (游戏套接口, 游戏封包, -1)
  363.         超级延时 (300)
  364.         Sk.发送 (游戏套接口, 游戏封包, -1)
  365.     .如果真结束

  366. .循环判断尾 ()
  367. 内存优化 (1)

  368. .子程序 转发服务封包
  369. .局部变量 服务封包, 字节集
  370. .局部变量 封包长度, 整数型
  371. .局部变量 服务封包2, 字节集
  372. .局部变量 封包长度2, 整数型

  373. .循环判断首 ()
  374.     封包长度 = Sk.接收 (服务套接口1, 服务封包, -1)
  375.     封包长度2 = Sk.接收 (服务套接口2, 服务封包2, -1)
  376.     .如果真 (封包长度 > 1)
  377.         Sk.置阻塞模式 (服务套接口1)
  378.         Sk.发送 (服务套接口1, 服务封包, -1)
  379.         超级延时 (300)
  380.         Sk.发送 (服务套接口2, 服务封包, -1)
  381.     .如果真结束
  382.     Sk.发送 (游戏套接口, 服务封包, -1)

  383. .循环判断尾 ()
  384. 内存优化 (1)

  385. .子程序 高精度等待
  386. .参数 毫秒, 整数型, , 1000毫秒 = 1秒
  387. .局部变量 hTimer, 整数型
  388. .局部变量 int64, LARGE_INTEGER

  389. int64.QuadPart = -10 × 毫秒 × 1000
  390. hTimer = CreateWaitableTimerA (0, 假, 0)
  391. SetWaitableTimer (hTimer, int64, 0, 0, 0, 假)
  392. .判断循环首 (MsgWaitForMultipleObjects (1, hTimer, 假, -1, 255) ≠ 0)
  393.     处理事件 ()
  394. .判断循环尾 ()
  395. CancelWaitableTimer (hTimer)

  396. .子程序 卡死频道
  397. .局部变量 数据, 文本型
  398. .局部变量 ID, 整数型
  399. .局部变量 筱焱, 文本型

  400. 置入代码 ({ 235, 16, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 98, 101, 103, 105, 110, 0 })  ' vmp保护标志头
  401. 置入代码 ({ 235, 7, 83, 69, 66, 69, 71, 78, 0 })
  402. 高精度等待 (100)
  403. .如果真 (进程是否存在 (“crossfire.exe”) = 真)
  404.     ID = 取进程ID (“crossfire.exe”)
  405.     .如果 (判断是否为64位系统 () = 真)
  406.         写内存文本型 (ID, 十六到十 (“02267964”), “连接不稳定”)
  407.         写内存文本型 (ID, 十六到十 (“0539E011”), “错误代码”)
  408.         写内存文本型 (ID, 十六到十 (“0539387E”), “您的网络出现异常”)
  409.         ' 读内存字节型 (ID, 十六到十 (“027DCD24”)) + 读内存字节型 (ID, 十六到十 (“027DCD04”)) + 读内存字节型 (ID, 十六到十 (“027DCCF4”))
  410.     .否则

  411.         写内存文本型 (ID, 十六到十 (“02267964”), “连接不稳定”)
  412.         写内存文本型 (ID, 十六到十 (“0539E011”), “错误代码”)
  413.         写内存文本型 (ID, 十六到十 (“0539387E”), “您的网络出现异常”)
  414.         ' 筱焱.读文本型 (ID, 十六到十 (“027DCD24”)) + 筱焱.读文本型 (ID, 十六到十 (“027DCD04”)) + 筱焱.读文本型 (ID, 十六到十 (“027DCCF4”))
  415.     .如果结束

  416. .如果真结束
  417. 结束检测进程事件 ()
  418. 置入代码 ({ 235, 7, 83, 69, 69, 78, 68, 80, 0 })
  419. 置入代码 ({ 235, 14, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 101, 110, 100, 0 })  ' vmp保护标志尾

  420. .子程序 结束检测进程事件

  421. 进程结束 (取进程ID (“TenSafe_1.exe”))
  422. 进程结束 (取进程ID (“TXPlatform.exe”))
  423. 进程结束 (取进程ID (“CrossProxy.exe”))
  424. 进程结束 (取进程ID (“TP3Helper.exe”))
  425. 进程结束 (取进程ID (“TenioDL.exe”))

  426. .子程序 _时钟1_周期事件



  427. .子程序 sking

  428. 置入代码 ({ 235, 16, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 98, 101, 103, 105, 110, 0 })  ' VMP过程加密开始
  429. Sk.连接 (二次套接, 服务器IP, 10008, 100)  ' 连接移到此处,防止空连接导致232
  430. 高精度等待 (1000)  ' 这里是过多少时间开始强登,卡是因为下面的二次连接会卡,这里时间长点,卡的也就慢点,3秒内偶尔代码,而且没那么卡
  431. Sk.发送 (二次套接, 字节集替换 (S_Data, 920, 7, { 1, 2, 3, 4, 5, 20, 238 }))
  432. PQ筱焱S.刷新显示 ()
  433. PQ筱焱S.调整层次 ()
  434. 高精度等待 (1000)
  435. PQ筱焱S.刷新显示 ()
  436. PQ筱焱S.调整层次 ()
  437. 高精度等待 (1000)
  438. PQ筱焱S.刷新显示 ()
  439. PQ筱焱S.调整层次 ()
  440. 置入代码 ({ 235, 14, 86, 77, 80, 114, 111, 116, 101, 99, 116, 32, 101, 110, 100, 0 })  ' VMP过程加密结束
  441. 返回 ()

  442. .子程序 注入插件

  443. .如果 (进程是否存在 (“crossfire.exe”) = 真)
  444.     GO ()
  445.     内存注入DLL_新 (取进程ID (“crossfire.exe”), , “CrossFire”, #dll)
  446. .否则
  447.     信息框 (“进入穿越火线游戏频道内按END开启辅助”, 0, “Hurt”, )
  448. .如果结束
  449. 优化cpu ()
  450. 优化cpu ()
  451. 优化cpu ()
  452. 优化cpu ()
  453. 优化cpu ()
  454. 优化cpu ()

  455. .子程序 优化cpu, , 公开

  456. 内存释放 (取当前进程句柄 (), -1, -1)
  457. 内存优化 (-2)
  458. 返回 ()
复制代码




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
加入挂坊高手群                           赚坊币                   开通VIP送坊币
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|挂坊论坛

GMT+8, 2020-2-25 03:55 , Processed in 0.093750 second(s), 38 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表